Integrating

Adding the YocoSDK-UI Pod

The SDK is distributed using Cocoapods. You can see their Getting Started guide.

You need to make three adjustments to your Podfile.

  1. Set use_frameworks!
  2. Add the custom Podspec repositories using source
  3. Add the YocoSDK-UI dependency to your target
use_frameworks!
source 'https://github.com/CocoaPods/Specs.git'
source 'https://bitbucket.org/payworks/io.payworks.repo.pods.git'
source 'https://gitlab.com/yoco-public/yoco-podspec'
target 'YourProject' do
pod 'YocoSDK-UI', '2.3.0'
end

Project Configuration

You need to add the following to your Info.plist

NameValue
Supported external accessory protocolscom.miura.shuttle
Required background modesApp communicates with an accessory, App downloads content from the network
Privacy - Location When In Use Usage DescriptionYour location is used to ensure the security of your Yoco payments

Disable Bitcode

In the Build Settings for your project, you must set Enable Bitcode to No

Importing the SDK

You can now import the SDK and start using it!

@import YocoSDK_UI;